Announcement

Collapse
No announcement yet.

Disappearing Apostrophes on iOS Safari

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Disappearing Apostrophes on iOS Safari

    I just noticed a rather odd error when I post from Safari on iOS. My apostrophes disappear after posting. I typed them in, but they simply donít [like here] show up in the post. I tried editing them in, but that didnít [and here] help.

    Iím on iOS 12.2 on an iPad Pro 10.5.

    Edit: Strange. It just worked here, but it didnít a minute ago over in the The Expanse forum.

    Edit 2: Even stranger. It seems my apostrophes disappear after editing, but not after the initial posting.
    Last edited by mrkwnzl; 05-16-2019, 12:57 PM.
    My AGE Character Sheets: https://roninarmy.com/forum/dragon-age-rpg-age-system/modern-age/8450-age-fan-made-character-sheets

  • #2
    Hmmm... I wonder if this has something to do with the types of quotation marks used:
    Straight: '
    Left: `
    Smart Left: Ď
    Smart Right: í

    And after edit:
    Straight: '
    Left: `
    Ďquoteí
    [url=http://roninarmy.com/threads/996]My Builds[/url]

    [b]Current games:[/b]
    [url=http://www.echoesofthemultiverse.com/viewtopic.php?f=15&t=839]The J.V. Team (GM)[/URL]

    Comment


    • #3
      So, it looks like Unicode single quotes don't fare so well, but that happens rather visibly. FWIW, I can still see all of your apostrophes in the first post, assuming the edit was done after adding them.
      [url=http://roninarmy.com/threads/996]My Builds[/url]

      [b]Current games:[/b]
      [url=http://www.echoesofthemultiverse.com/viewtopic.php?f=15&t=839]The J.V. Team (GM)[/URL]

      Comment


      • #4
        Originally posted by FuzzyBoots View Post
        So, it looks like Unicode single quotes don't fare so well, but that happens rather visibly. FWIW, I can still see all of your apostrophes in the first post, assuming the edit was done after adding them.
        Okay, thatís super weird. They re-appeared. Am I crazy? They werenít there after editing!
        My AGE Character Sheets: https://roninarmy.com/forum/dragon-age-rpg-age-system/modern-age/8450-age-fan-made-character-sheets

        Comment


        • #5
          Sorry for the double post, but I didnít want to edit my last post. I definitely put some apostrophes there, but they are missing, even without editing.
          My AGE Character Sheets: https://roninarmy.com/forum/dragon-age-rpg-age-system/modern-age/8450-age-fan-made-character-sheets

          Comment


          • #6
            I can see them. They are curved, which means they are not single apostrophes and therefore are not ASCII, which might prove the difference.
            [url=http://roninarmy.com/threads/996]My Builds[/url]

            [b]Current games:[/b]
            [url=http://www.echoesofthemultiverse.com/viewtopic.php?f=15&t=839]The J.V. Team (GM)[/URL]

            Comment


            • #7
              I donít know about ASCII (havenít had the need to look deep into that), but Iím using the iOS default for typographical apostrophes, which should be unicode U+2019.
              My AGE Character Sheets: https://roninarmy.com/forum/dragon-age-rpg-age-system/modern-age/8450-age-fan-made-character-sheets

              Comment


              • #8
                Maybe itís related to some kind of cache problem. I canít see any typographical characters (apostrophes and quotes) before I reload the page. After reloading, they appear.

                Not many people use typographical characters, so I missed it before, but it also affects the posts of others, not just mine.

                Also: Seems to be a problem on macOS Safari and Firefox, too.
                Last edited by mrkwnzl; 05-21-2019, 06:57 AM.
                My AGE Character Sheets: https://roninarmy.com/forum/dragon-age-rpg-age-system/modern-age/8450-age-fan-made-character-sheets

                Comment

                Working...
                X